top of page
  • Writer's pictureMcCube

Dive into EthernetChannels

Updated: Oct 27, 2023


This Lab was created by MyMindsMadness

If you require any assistance please email


Download Lab here


This lab is designed to help you better understand Ether Channel.


There are 3 parts to this lab.


Understand a looped network.

Firstly, click in to the STP topology.

This is a simple switch topology.

It consists of

  • 3 switches all connected

  • Each switch has 2 end devices connected

  • Each end device is in a different VLAN (10 and 192)

  • Each switch is connected to another via a single trunk link

You can confirm this by using commands

show interface status
show vlan
show interface trunk

on any of the switches


The interesting element of this topology is that one of the links between the switches is currently Amber.

This is because a looped topology has been detected and Spanning tree has quite rightfully put an interface in a blocking mode to prevent a broadcast storm taking over the network.


You can use the "show spanning-tree summary" to see which vlans are being blocked

S3#show spanning-tree summary 
---[output omitted]---
Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001                     1         0        0          1          2
VLAN0010                     1         0        0          2          3
VLAN0192                     1         0        0          2          3
---------------------- -------- --------- -------- ---------- ----------
3 vlans                      3         0        0          5          8

In addition, you can use the "show spanning-tree interface fastethernet0/1" to see more details of the interface state.

S3#show spanning-tree interface fastEthernet 0/1
Vlan             Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
VLAN0001         Altn BLK 19        128.1     P2p
VLAN0010         Altn BLK 19        128.1     P2p
VLAN0192         Altn BLK 19        128.1     P2p
S3#

The "show spanning-tree active" command also displays very useful information. (I have omitted everything other than vlan 10.)

S3#show spanning-tree active 
---[output omitted]---
VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    32778
             Address     0001.9692.532D
             Cost        19
             Port        2(FastEthernet0/2)
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     00E0.F730.38E2
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20
Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Altn BLK 19        128.1    P2p
Fa0/2            Root FWD 19        128.2    P2p
Fa0/4            Desg FWD 19        128.4    P2p
---[output omitted]---
S3# 

While this is all very interesting it doesn't actually tell us anything about etherchannels. This behaviour however, is key to helping you understand one of the benefits that etherchannels have.


Select the "Back" arrow at the top right of the screen or "alt+left" to go back to the view of the 2 clouds.


Configure Etherchannels


Select the "Ether Channel" cloud.

This topology is exactly the same as the first, however we have introduced 3 new cables between the switches.


In packet tracer we can quickly see that something is wrong here. Notice the link lights.

4 of the 6 links are currently in a blocking state. This is because spanning tree is working extremely harder in this topology.


While every link is a single link, spanning tree views this as a total of 4 looped topologies.

There is potential for a loop between

Sw1 and Sw2

Sw1 and Sw3

Sw2 and Sw4

Sw1 through Sw2 through Sw3


This got messy fast. And it is infuriatingly inefficient. We tried to double our bandwidth between the switches and are still no better off. As there is still only 1 valid loop free path available. (my topology has worked this out as Sw1 > Sw2 > Sw3 (there is a possibility that yours may vary))

Now we have the need for Ether Channels!!!


We will configure this in a few different ways, but at each stage take a moment to assess the topology and the link lights. See what is happening.


Configure Etherchannels (PAgP Part 1)


To start we will focus on the links between Sw1 and Sw2.

We will configure this using Port Aggregation protocol. (PAgP)


On Sw1. Interfaces Fastethernet 0/2 and Fastethern0/5 are the links to Sw2.

While it is common to physically group etherchannels together (e.g. Fa0/1 and Fa0/2) This is not always possible and it is good to also understand that interfaces do not need to be contiguous.


Our first task will be to place these interfaces into a channel group. In this instance Channel group 1 using the PAgP "Desirable" setting .

(I have included the contextual help to show the different etherchannel modes available.)

Sw1(config)#int range f0/2 , f0/5
Sw1(config-if-range)#channel-group 1 mode ?
  active     Enable LACP unconditionally
  auto       Enable PAgP only if a PAgP device is detected
  desirable  Enable PAgP unconditionally
  on         Enable Etherchannel only
  passive    Enable LACP only if a LACP device is detected
Sw1(config-if-range)#channel-group 1 mode desirable 
Sw1(config-if-range)#exit

The next step is to configure the port channel as a trunk link that permits vlans 10 and 192 to cross it.


In the STP topology this was done within the interface fastethernet. Here we can now configure both interfaces under the port channel.


(One thing I always hated, "Port Channel" and "Channel Group". By using command "channel-group 1..." We have made the interface "port-channel 1)

Sw1(config)#interface port-channel 1
Sw1(config-if)#switchport mode trunk 
Sw1(config-if)#switchport trunk allowed vlan 10,192
Sw1(config-if)#end

We can now view this configuration within the running config. Notice how the switchport configuration has been applied to both the port channel and the interfaces within it?

Sw1#show run | section interface
interface Port-channel1
 switchport trunk allowed vlan 10,192
 switchport mode trunk 
---[output omitted]---
interface FastEthernet0/2
 switchport trunk allowed vlan 10,192
 switchport mode trunk
 channel-group 1 mode desirable
---[output omitted]---
interface FastEthernet0/5
 switchport trunk allowed vlan 10,192
 switchport mode trunk
 channel-group 1 mode desirable
Sw1#

You can also see a summary of the etherchannel using command show etherchannel port-channel summary

However, because the other end is not currently configured, you will not get a great deal of information.

Sw1#show etherchannel port-channel 
                Channel-group listing:
                ----------------------
Group: 1
----------
                Port-channels in the group:
                ---------------------------
Port-channel: Po1
------------
Age of the Port-channel   = 00d:00h:17m:11s
Logical slot/port   = 2/1       Number of ports = 2
GC                  = 0x00000000      HotStandBy port = null
Port state          = Port-channel 
Protocol            =   PAGP
Port Security       = Disabled
Ports in the Port-channel:
Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Fa0/2    Desirable-Sl       0
  0     00     Fa0/5    Desirable-Sl       0
Time since last port bundled:    00d:00h:03m:49s    Fa0/5

Turn your attention to Sw2 and repeat the steps. Sw2 also uses links Fa0/2 and Fa0/5 so the commands will all be identical.

Sw2#conf t
Sw2(config)#int range f0/2, f0/5
Sw2(config-if-range)#channel-group 1 mode desirable
Sw2(config)#interface port-channel 1
Sw2(config-if)#switchport mode trunk 
Sw2(config-if)#switchport trunk allowed vlan 10,192
Sw2(config-if)#

Before going any further have a look at the topology. The links between Sw1 and Sw2 should now be green. This is because both interfaces are now seen as a single logical interface "Port-channel 1" not fa0/2 and fa0/5.


Configure Etherchannels (PAgP Part 2)


In the links between Sw1 and Sw2 we utilised the "desirable" mode

For fun let's use the "auto" mode between Sw2 and Sw3

Also, because we have already used "Channel-Group 1" on Sw2, we need to create a new port channel.

In this instance we will create channel group 2.


On Sw2 the links to Sw3 are FastEthernet 0/1 and FastEthernet 0/6 so we will need to place these interfaces in to channel group 2.

Sw2#conf t
Sw2(config)#int range f0/1, f0/6
Sw2(config-if-range)#channel-group 2 mode auto 
Sw2(config)#int po2 #This is just short hand for "interface Port-channel2"
Sw2(config-if)#switchport mode trunk 
Sw2(config-if)#switchport trunk allowed vlan 10,192
Sw2(config-if)#exit
Sw2(config)#

Excellent, now let's repeat this on Sw3. However, let's (also for fun) use port-channel 1 on Sw3 because that doesn't exist yet.

Also, the links on Sw3 the go to Sw2 are FastEthernet 0/2 and FathEthernet 0/5. This helps us see two things that can be described in one way.

Symmetry is not a requirement. We do not need to have the same numbered physical interface, or the same logical interface numbers.

The biggest requirement with Port channels is that they are the SAME INTERFACE TYPE. FastEthernet to FastEthernet, GigabitEthernet to GigabitEthernet.

The one thing that will not work is trying to bundle a FastEthernet interface and a GigabitEthernet interface into the same port channel.

Sw3#
Sw3#conf t
Sw3(config)#int ra f0/2, f0/5
Sw3(config-if-range)#channel-group 1 mode auto 
Sw3(config-if-range)#exit
Sw3(config)#
Sw3(config)#int po1
Sw3(config-if)#switchport mode trunk 
Sw3(config-if)#switchport trunk allowed vlan 10,192
Sw3(config-if)#

Ok, but wait... something is wrong.

unlike between Sw1 and Sw2 where all the lights went green... one of the interfaces is still down.

You don't get this visible confirmation in the real world, this is why verifying your work is such an important step.

Let's see what's going wrong.


We should firstly use the "show etherchannel summary" command to give us an idea of the status of our new channel.

I have highlighted the important elements here. The Flags in use are "D" and "I".

Sw3#show etherchannel summary 
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-----------+------+---------------------------------------------
1      Po1(SD)      PAgP   Fa0/2(I) Fa0/5(I) 
Sw3#

If we look at Sw2 we should get information that we can use in comparison. This is because Sw2 has a current working Port channel.

Again, I have highlighted important elements, and added a small note for clarity

Sw2#show etherchannel summary 
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
Number of channel-groups in use: 2
Number of aggregators:           2
Group  Port-channel  Protocol    Ports
------+-----------+------+---------------------------------------------
1      Po1(SU)      PAgP   Fa0/2(P) Fa0/5(P) #Note: Port channel to Sw1
2      Po2(SD)      PAgP   Fa0/1(I) Fa0/6(I) #Note: Port channel to Sw3 
Sw2# 

Why is Po1 to Sw1 active but Po2 to Sw3 disabled and importantly the interfaces showing as "stand alone" this mean they are not participating as a single logical interface, rather two Independant interfaces.

This is because when configuring the channel, we used the "auto" mode on both ends, this method is passive, so does not actively seek to create an Ether channel and two passives don't make a right.

We can still use Auto, but still need at least one end to be active. As we are currently on Sw2, let's configure its interfaces as "desirable".

Sw2#conf t
Sw2(config)#int range f0/1, f0/6
Sw2(config-if-range)#channel-group 2 mode desirable 
Sw2(config-if-range)#

The console feedback is very useful here.

Sw2(config-if-range)#
%LINK-5-CHANGED: Interface Port-channel2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel2, changed state to up
Sw2(config-if-range)#

In addition, the show etherchannel summary will show us a change in the status.

Sw2#show etherchannel summary 
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
Number of channel-groups in use: 2
Number of aggregators:           2
Group  Port-channel  Protocol    Ports
------+---------+-------+----------------------------------------------
1      Po1(SU)    PAgP   Fa0/2(P) Fa0/5(P) 
2      Po2(SU)    PAgP   Fa0/1(P) Fa0/6(P) 
Sw2#

Configure Etherchannels (LACP)


Finally, Lets focus on the links between Sw1 and Sw3.

On these interfaces we will use Link Aggregation Control Protocol. (LACP)

Start with Sw1. Again, I have included contextual help (?) to show the available options.

Sw1#conf t
Sw1(config)#interface range f0/1 , f0/6
Sw1(config-if-range)#channel-group 2 mode ?
  active     Enable LACP unconditionally
  auto       Enable PAgP only if a PAgP device is detected
  desirable  Enable PAgP unconditionally
  on         Enable Etherchannel only
  passive    Enable LACP only if a LACP device is detected
Sw1(config-if-range)#channel-group 2 mode passive 
Sw1(config-if-range)#exit
Sw1(config)#int po2
Sw1(config-if)#switchport mode trunk 
Sw1(config-if)#switchport trunk allowed vlan 10,192

Move on to Sw3.

Similar to PAgP, if we were to configure the Channel Group as passive, we will end up with 2 passive ends and the ether channel will not form.

So, we should configure the other end as "Active".

Sw3#conf t
Sw3(config)#interface range f0/1, f0/6
Sw3(config-if-range)#channel-group 2 mode active
Sw3(config-if-range)#exit
Sw3(config)#int po2
Sw3(config-if)#switchport mode trunk 
Sw3(config-if)#switchport trunk allowed vlan 10,192
Sw3(config-if-range)#do show etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
Number of channel-groups in use: 2
Number of aggregators:           2
Group  Port-channel  Protocol    Ports
------+---------+-------+----------------------------------------------
1      Po1(SU)    PAgP   Fa0/2(P) Fa0/5(P) 
2      Po2(SU)    LACP   Fa0/1(P) Fa0/6(P) 
Sw3(config-if-range)#

Compare both STP and EtherChannel Topologies


Finally, look at the topology now. Notice that rather than 4 links down in a blocking state, now there is only "1".

(Something I have noted from Packet Tracer, is that, when Per VLAN Spanning Tree is in operation. The link lights will only represent 1 of the VLANs. Most likely vlan 1 (or if it is disabled the first active VLAN))

We have effectively recreated the same topology from the "STP" page but with double bandwidth.


Well done. If you have any questions please do not hesitate to ask.

Message or leave a comment.





49 views0 comments

Recent Posts

See All

Comments


bottom of page